Enabling SKIPPING SMS workflow step

When my workflow includes a step to send an SMS, but the lead has either no mobile phone on file or requested to stop SMS (using Twilio), the SMS step apparently will then NOT be skipped and the flow does not continue with the next step - i.e. send an email
(see my workflow example here)

I want to always first send both email and SMS messages (which are stopped as soon as the desired CTA has been done by the lead). I don’t know, how I can continue with emails, when the SMS can’t be sent anymore, or not at all, if the lead has no phone number to begin with.(Can’t seem to auto-tag leads that have no phone number)

My suggestion is to ENABLE SKIPPING the SMS workflow step in this scenario or let me know, how I could otherwise solve this challenge.

Thanks